This topic contains 31 replies, has 6 voices, and was last updated by  LemurTech 5 months, 1 week ago.

  • Author
    Posts
  • #5903
     Paul 
    Member

    I am getting the following error when trying to update via the web gui dashboard.

    00:00:00
    Machine IDs to update: 6
    00:00:00
    SYSTEM_GET_MACHINES_FOR_UPDATE
    00:00:00
    Server Enterprise Server found
    00:00:00
    Server Mail Server found
    00:00:00
    Server MySQL Server found
    00:00:00
    Machines to update: MySQL Server
    00:00:00
    Start updating MySQL Server
    00:00:00
    Server MySQL Server failed to update. See MSPCInstallation.log.txt for more details (please find it by the file search)
    Message did not meet security requirements.
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at MSPControl.EnterpriseServer.SystemController.DoUpgrade(Int32 serverId, String serverName, Guid guid)

    Downloading the installer and running it works perfectly.

    I see there is another question at the moment with the same sort of error here

    I cannot find the MSPCInstallation.log.txt file – where should I look?

    Any other suggestions?

    Many Thanks
    Paul

    0
    Be the first one to like this.
    Please wait...
    #5904
     Alexander 
    Member

    Hi
    What the version of Windows on your MySQL Server?

    0
    Be the first one to like this.
    Please wait...
    #5905
     Paul 
    Member

    Server 2012 R2 Standard – It used to work, but tbh, I have just put up with it recently.
    Last time it was working was about 2 months ago.

    0
    Be the first one to like this.
    Please wait...
    #5906
     Alexander 
    Member

    Is there a way to connect to your Server for checking? please write me AlexT@mspcontrol.org

    0
    Be the first one to like this.
    Please wait...
    #5907
     Paul 
    Member

    Emailed you Alex.

    0
    Be the first one to like this.
    Please wait...
    #6213
     Ballou 
    Member

    Any solution to this?
    I have the same error when trying to reach a WEB server from MSPC.

    0
    Be the first one to like this.
    Please wait...
    #6216
     Paul 
    Member

    No solution as of yet – I havent heard back from Alexander since he remoted to take a look.

    0
    Be the first one to like this.
    Please wait...
    #6226
     Alexander 
    Member

    Related fix is pushed. Please update to the latest and resave the Server component Password (just on Server Details page). After that please test. Is it help?

    0
    Be the first one to like this.
    Please wait...
    #6227
     Ballou 
    Member

    Thanks Alex. This worked perfect.

    0
    Be the first one to like this.
    Please wait...
    #6229
     Paul 
    Member

    Fix applied, but for my particular issue, I now need to wait for the next build to be released in order to test.

    0
    Be the first one to like this.
    Please wait...
    #6237
     Paul 
    Member

    Tried to update via the dashboard, but still get the same error:

    Server MySQL Server failed to update. See MSPCInstallation.log.txt for more details (please find it by the file search)
    Message did not meet security requirements.
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at MSPControl.EnterpriseServer.SystemController.DoUpgrade(Int32 serverId, String serverName, Guid guid)

    0
    Be the first one to like this.
    Please wait...
    #6238
     Ivan 
    Member

    Hi Paul, please update all components manually then, thank you

    0
    Be the first one to like this.
    Please wait...
    #6239
     Paul 
    Member

    Sorry – maybe I wasnt clear…. I updated manually to build 2780 to apply the fix – I then re-entered and saved the password for the server as above.

    Now that 2782 has been released I tried it via the dashboard, but still get the same result.

    0
    Be the first one to like this.
    Please wait...
    #6240
     Ivan 
    Member

    Hi Paul, please check what is the build you’re using, if it’s earlier than – Date: 2017-02-15 06:27:33
    Description: Fix “Message did not meet security” for Server then, of course the issue is not fixed. If update via dashboard hasn’t worked, please update all MSPControl components manually.

    0
    Be the first one to like this.
    Please wait...
    #6241
     Paul 
    Member

    Please re-read from post #6229 above.
    Build with the fix (2780) has been applied today…manually.
    Then waited for a further build (2782) – which would not apply via the dashboard.

    0
    Be the first one to like this.
    Please wait...
    #6242
     Ivan 
    Member

    Hi Paul, I reread this thread each time there is a notification. Sorry, but I cannot understand your problem right now. The initial problem is fixed and the builds are provided. If there is a fail in upgrade via dashboard you can a) check what is the reason and b) check what is the reason and upgrade manually. So I wonder where I fail and you’re welcome to correct me 🙂

    0
    Be the first one to like this.
    Please wait...
    #6243
     Paul 
    Member

    The problem was fixed in 2780 as I understand it. I applied this manually this morning, so it should have fixed my original problem.

    Using the dashboard this afternoon to update to the newer, 2782 build, and still get the same problem.

    Im sorry, Im not trying to be difficult, but I really dont know how I can explain this any better.
    Wuold you like remote access to my servers to see the problem?

    0
    Be the first one to like this.
    Please wait...
    #6244
     Ivan 
    Member

    Thank you, Paul, much clearer now

    0
    Be the first one to like this.
    Please wait...
    #6245
     Paul 
    Member

    So do I need to do anything, or is there still an unresolved issue.
    Its not a major problem – I can just update manually as I have been doing, but just wondered.

    0
    Be the first one to like this.
    Please wait...
    #6253
     Alexander 
    Member

    Paul, what the password do you use for the problem Server? Could you write it? Could you please try to set simple password like 123456?

    0
    Be the first one to like this.
    Please wait...
Viewing 20 posts - 1 through 20 (of 32 total)

You must be logged in to reply to this topic.

Contact Us

We're not around right now. But you can send us an email and we'll get back to you, asap.

Sending

©2017 MSPControl | Privacy Policy

Log in with your credentials

or    

Forgot your details?

Create Account