This topic contains 6 replies, has 4 voices, and was last updated by  alexeev.evg 4 months, 1 week ago.

  • Author
    Posts
  • #9400
     Nigel Freeney 
    Member

    Build 6358

    I am seeing an error that I have seen at least three times over the last year or so. I get an email showing me the status that a certificate renewal has failed.

    I try to renew it manually by deleting the existing certificate – this reports successfully completed.

    I try to add a new certificate – again this reports successfully completed.

    However, when I check the date of the certificate has not been changed.

    Please advise?

    Thanks,

    Nigel

    0
    Be the first one to like this.
    Please wait...
    #9401
     Nigel Freeney 
    Member

    This is the error message

    This is the error message

     

    Error_Installing_certificate:System.Web.Services.Protocols.SoapException: Server was unable to process request. —>

    System.Runtime.InteropServices.COMException: A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520) at MSPControl.Providers.Web.Iis.SSLModuleService80.HandleExceptionAndRollbackCertificate(X509Store store, X509Certificate2 x509Cert, SSLCertificate oldCert, WebSite webSite, String errorMessage, Exception ex) at MSPControl.Providers.Web.Iis.SSLModuleService80.InstallPfx(Byte[] certificate, String password, WebSite website) at MSPControl.Server.WebServer.installPFX(Byte[] certificate, String password, WebSite website) — End of inner exception stack trace —

     

    2
    2 people like this.
    Please wait...
    #9476
     MSPControl 
    Keymaster

    This should be fixed in latest 2.0

    0
    Be the first one to like this.
    Please wait...
    #9481
     Ho Shan Yeow 
    Member

    Hi, I have upgrade to MSP 2.0 with the latest ACME.
    But still get the following error for renewal and also new SSL.
    I have a few domains host in the same server, I test to install SSL on other domains in the same server and get the same result below.

    “Could not validate the choosen hostname for the certificate – the given identifier was not found in the registry. No certificate issued.”

    0
    Be the first one to like this.
    Please wait...
    #9482
     Ho Shan Yeow 
    Member

    From the Windows event log, I get the following error.

    Is the problem related to the particular version of ACMESharp?
    Previously I am using MSP 1.0 with ACME 8.x, that time we tested the latest ACME and it doesn’t work with MSP 1.0.

    Now with MSP 2.0, the old ACME doesn’t work so I install the latest ACME and get the error below.

    “LetsEncrypt is unable to validate domain xxx.com on site xxx.com
    System.Management.Automation.CmdletInvocationException: the given identifier was not found in the registry —> System.Collections.Generic.KeyNotFoundException: the given identifier was not found in the registry
    at ACMESharp.Ext.ExtRegistry`2.Get(String key) in C:\projects\acmesharp\ACMESharp\ACMESharp\Ext\ExtRegistry.cs:line 109
    at ACMESharp.ACME.ChallengeHandlerExtManager.GetProvider(String name, IReadOnlyDictionary`2 reservedLeaveNull) in C:\projects\acmesharp\ACMESharp\ACMESharp\ACME\ChallengeHandlerExtManager.cs:line 41”

    0
    Be the first one to like this.
    Please wait...
    #9485
     alexeev.evg 
    Member

    What version is installed? 0.9.1.326?

    0
    Be the first one to like this.
    Please wait...
    #9486
     alexeev.evg 
    Member

    What version is installed? 0.9.1.326?

    0
    Be the first one to like this.
    Please wait...
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

©2019 MSPControl | Privacy Policy

Log in with your credentials

or    

Forgot your details?

Create Account