This topic contains 8 replies, has 5 voices, and was last updated by  Gulfaraz Ahmed 4 months, 3 weeks ago.

  • Author
    Posts
  • #4173
     Richard Shafer 
    Member

    I am receiving this error after upgrading to the MSPControl from the Website Panel: The request failed with HTTP status 400: Bad Request. See the full stack trace below.

    I followed the suggestions in posts regarding the setting the <EnterpriseServer>http://[to the servers IP xxx.xxx.xxx.xxx]:9002</EnterpriseServer> and I still receive the same error.

    I am in a bind and need to resolve this quickly for a client, Thank You!!

    Stack Trace: System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. —> System.Net.WebException: The request failed with HTTP status 400: Bad Request.
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at MSPControl.Providers.Web.WebServer.GetSite(String siteId)
    at MSPControl.EnterpriseServer.WebServerController.GetWebSite(Int32 siteItemId)
    at MSPControl.EnterpriseServer.esWebServers.GetWebSite(Int32 siteItemId)
    — End of inner exception stack trace —
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at MSPControl.EnterpriseServer.esWebServers.GetWebSite(Int32 siteItemId)
    at MSPControl.Portal.WebSitesEditSite.BindWebSite()

    Thank you,
    Richard Shafer

    0
    Be the first one to like this.
    Please wait...
    #4251
     Ralph O’Brien IV 
    Member

    I too had the same problem. Apparently MSP Control has no idea how to handle this since I have seen no reasonable explanation. I went from a perfectly working WebSite Panel product to a completely non-working control panel.

    0
    Be the first one to like this.
    Please wait...
    #4254
     Anonymous

    Richard, was this ever resolved?

    0
    Be the first one to like this.
    Please wait...
    #4255
     Alexander 
    Member

    Is it possible to connect to your server to check the issue? Please contact me AlexT@mspcontrol.org

    0
    Be the first one to like this.
    Please wait...
    #4263
     Alexander 
    Member

    Please go to the Setting -> Servers menu, enter the password for the server and click Update Password button. It should help.

    If not – please run the installer, change the server password and update the password on Server Settings page.

    We will fix this bug of the installation soon, thank you.

    1
    1 person likes this.
    Please wait...
    #4264
     Richard Shafer 
    Member

    AWESOME, that worked!!!

    Thanks Alex!!

    Richard

    0
    Be the first one to like this.
    Please wait...
    #4265
     Alexander 
    Member

    And make sure that Address on Server Settings page leads to the IIS Server WebSite (like http://binding-ip-address:9003)

    0
    Be the first one to like this.
    Please wait...
    #4267
     Richard Shafer 
    Member

    AWESOME, thanks for pointing that out. After all the changes were made it worked!!!

    Thanks Alex!!

    Richard

    0
    Be the first one to like this.
    Please wait...
    #8582
     Gulfaraz Ahmed 
    Member

    Just like to inform if someone still facing the issues even applying the changes discussed above :

    I overcame this after reverting mspcontrol back to websitepanel and then upgrading to another similar/forked control panel.

    (I was also facing this issue : https://mspcontrol.org/forums/topic/the-security-token-could-not-be-authenticated-or-authorized/#post-8581)

    Regards,

    Gul

    0
    Be the first one to like this.
    Please wait...
Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

©2018 MSPControl | Privacy Policy

Log in with your credentials

or    

Forgot your details?

Create Account