This topic contains 6 replies, has 3 voices, and was last updated by  Ho Shan Yeow 2 months ago.

  • Author
    Posts
  • #9053
     Ho Shan Yeow 
    Member

    The current MSPControl build that I download today, will generate the following error when add website pointer.
    Two of our servers that just update to latest MSPControl encounter the exact same problem, when you create a website the error will appear.
    However, the website is created but there is no “www” pointer.

    System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. —> System.Exception: Error executing ‘ADD’ task on ‘2mfurniture.com’ WEB_SITE —> System.Exception: Error executing ‘ADD’ task on ‘domain.com’ WEB_SITE —> System.NullReferenceException: Object reference not set to an instance of an object.
    at MSPControl.EnterpriseServer.WebServerController.AddWebSitePointer(Int32 siteItemId, String hostName, Int32 domainId, Boolean updateWebSite, Boolean ignoreGlobalDNSRecords, Boolean rebuild)
    — End of inner exception stack trace —
    at MSPControl.EnterpriseServer.WebServerController.AddWebSitePointer(Int32 siteItemId, String hostName, Int32 domainId, Boolean updateWebSite, Boolean ignoreGlobalDNSRecords, Boolean rebuild)
    at MSPControl.EnterpriseServer.WebServerController.AddWebSite(Int32 packageId, String hostName, Int32 domainId, Int32 packageAddressId, Boolean addInstantAlias, Boolean ignoreGlobalDNSRecords)
    — End of inner exception stack trace —
    at MSPControl.EnterpriseServer.WebServerController.AddWebSite(Int32 packageId, String hostName, Int32 domainId, Int32 packageAddressId, Boolean addInstantAlias, Boolean ignoreGlobalDNSRecords)
    at MSPControl.EnterpriseServer.esWebServers.AddWebSite(Int32 packageId, String hostName, Int32 domainId, Int32 ipAddressId, Boolean ignoreGlobalDNSZone)
    — End of inner exception stack trace —
    at MSPControl.EnterpriseServer.BusinessErrorCodes.GetMessage(SoapException ex, Boolean code)
    at MSPControl.Portal.MSPControlModuleBase.ShowErrorMessage(String moduleName, String messageKey, Exception ex, String[] additionalParameters)

    0
    Be the first one to like this.
    Please wait...
    #9056
     Ho Shan Yeow 
    Member

    Upon further investigation, when add a website together with its pointer “www”, it doesn’t create the database row in MSSQL ‘Domains’ table.

    However, the website can appear in MSPC even though there is no data row inside the table ‘Domains’.
    Since there is no database row to represent the website and its pointer in the ‘Domains’ table, when adding or deleting SSL will screw up other websites that doesn’t have rows in ‘Domains’ table!

    All issues originated from adding website pointer for the main domain and its pointer ‘www’.
    Can fix this quickly?

    0
    Be the first one to like this.
    Please wait...
    #9073
     alexeev.evg 
    Member

    This error is fixed in latest version. Please try download new version.

    0
    Be the first one to like this.
    Please wait...
    #9079
     Ho Shan Yeow 
    Member

    Hi, thank you for the reply but I still encounter the same problem with the latest build 1.0.0.6332.
    I updated another MSPControl server that doesn’t have this problem before but the problem appears after the upgrade.

    In IIS, it is able to create binding for both naked domain and www, however in MSPControl it shows error.
    Because of this, you will get the same error when you create a new hosting account that has website hosting space.
    Without the www pointer in MSPControl, you will not be able to generate SSL for “www” domain.
    Please help as this problem can be serious as we are not able to create new hosting account and generate SSL.

    Below is the error I encounter (same error) with the latest build.

    System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. —> System.Exception: Error executing ‘ADD’ task on ‘domain.com’ WEB_SITE —> System.Exception: Error executing ‘ADD’ task on ‘domain.com’ WEB_SITE —> System.NullReferenceException: Object reference not set to an instance of an object.
    at MSPControl.EnterpriseServer.WebServerController.AddWebSitePointer(Int32 siteItemId, String hostName, Int32 domainId, Boolean updateWebSite, Boolean ignoreGlobalDNSRecords, Boolean rebuild)

    0
    Be the first one to like this.
    Please wait...
    #9082
     alexeev.evg 
    Member

    i made fix in 1.0. you can download new version.

    1
    1 person likes this.
    Please wait...
    1 user thanked author for this post.
    #9086
     Herold 
    Member

    Same error here!

    0
    Be the first one to like this.
    Please wait...
    #9092
     Ho Shan Yeow 
    Member

    Indeed, the error has been fixed in the latest build.

    thanks.

    0
    Be the first one to like this.
    Please wait...
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

©2019 MSPControl | Privacy Policy

Log in with your credentials

or    

Forgot your details?

Create Account