This topic contains 8 replies, has 5 voices, and was last updated by  MSPControl 3 months ago.

  • Author
    Posts
  • #8452
     Jean-Michel DION 
    Member

    Hi,

    Since lastest update we encountered issue updating distribution list members

    [4/19/2018 6:18:35 PM] ERROR: ‘Hosted Microsoft Exchange Server 2016’ SetDistributionListGeneralSettings
    System.NullReferenceException: Object reference not set to an instance of an object.
    at MSPControl.Providers.HostedSolution.ExchangeBase.<>c.VqlpUYXqXIclhw6OWaK(Object )
    at MSPControl.Providers.HostedSolution.ExchangeBase.<>c.<SetDistributionListGeneralSettingsInternal>b__229_0(ExchangeAccount m)
    at System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext()
    at System.Linq.Buffer<code>1..ctor(IEnumerable</code>1 source)
    at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)
    at MSPControl.Providers.HostedSolution.ExchangeBase.SetDistributionListGeneralSettingsInternal(String accountName, String displayName, Boolean hideFromAddressBook, ExchangeAccount[] managedBy, ExchangeAccount[] memberAccounts, String notes, String[] addressLists)
    at MSPControl.Providers.HostedSolution.ExchangeBase.QG3itQQmMbL1jVa5YmS(Object , Object , Object , Boolean hideFromAddressBook, Object , Object , Object , Object )
    at MSPControl.Providers.HostedSolution.ExchangeBase.SetDistributionListGeneralSettings(String accountName, String displayName, Boolean hideFromAddressBook, ExchangeAccount[] managedBy, ExchangeAccount[] members, String notes, String[] addressLists)
    at MSPControl.Server.ExchangeServer.y8DFqRjHp0jQ3ulMoqU(Object , Object , Object , Boolean , Object , Object , Object , Object )
    at MSPControl.Server.ExchangeServer.SetDistributionListGeneralSettings(String accountName, String displayName, Boolean hideFromAddressBook, ExchangeAccount[] managedBy, ExchangeAccount[] members, String notes, String[] addressLists)

    0
    Be the first one to like this.
    Please wait...
    #8453
     Jean-Michel DION 
    Member

    Hi,

    I’ve found when adding old accounts to the distribution list
    old account have : AccountNameHash, PrimaryEmailAddressHash set to NULL in mspc database.

    If I update the account general tab, AccountNameHash, PrimaryEmailAddressHash is set to <Binary data> and I can add user to the Distribution list.

    Please could you correct these issue

    Best regards

    0
    Be the first one to like this.
    Please wait...
    #8532
     Jean-Michel DION 
    Member

    Hi,

    Corrected

    Thank you

    0
    Be the first one to like this.
    Please wait...
    #8562
     Morten J 
    Member

    We updated MSP to vers. 5542 and when we save distribution lists we get this error:
    Error updating distribution list general settings. See audit log for more details.

    Server was unable to process request. —> Error executing ‘UPDATE_DISTR_LIST_GENERAL’ task on ‘testdist@xxxxx.dk’ EXCHANGE —> Server was unable to process request. —> Object reference not set to an instance of an object.

    0
    Be the first one to like this.
    Please wait...
    #8571
     Thomas Sinding 
    Member

    This is still not working after update to vers. 5621.

    Is there a known work around for this issue or will it be fixed??

    0
    Be the first one to like this.
    Please wait...
    #8572
     Thomas Sinding 
    Member

    What binary value did you update, AccountNameHash, PrimaryEmailAddressHash to?

    0
    Be the first one to like this.
    Please wait...
    #8579
     Ben Filippelli 
    Member

    We are having a similar error that I spent 2 days trying to track down, and ended up removing and re-creating a dozen DG’s and now the error is gone but adding contacts or other non-users seems to just not work although you dont get an error it accepts it and the audit log shows it was added , but then when you go back in the contact was not added.

    I think this has been broken for awhile a client has asked us for the past several weeks to add the users to DG’s for them through AD we thought it was just one or two issues but turns out to be all clients on both 2013 and 2016 this is not working properly.

    thank you

    0
    Be the first one to like this.
    Please wait...
    #8599
     Morten J 
    Member

    We have found out that if you add a distrubution list to another distrubution list on the members of tab, then i will go right trough without error. But about the contacts it’s still problem to add them to distrubution lists.
    And we can also not add other distrubution list to a larger distrubution list within that list it self onlythe other way around.

    0
    Be the first one to like this.
    Please wait...
    #8635
     MSPControl 
    Keymaster

    Everyone I think that in latest most distribution list issues is resolved. We found that probably the largest issue had to do with how they were being searched for (CN). We found that we expected CN= to be same as SAMAccountName but with Imported users we were not resetting their CN to the SamAccountName (not to mess with the users existing Display name). It looking for CN goes back all the way to Websitepanel, and we added import abilities about 6 months ago. I would imagine most of you imported a lot of the users into MSPC using the import functionality.

    If you still have issues on latest please report them to support@mspcontrol.org and I will check into them.

    0
    Be the first one to like this.
    Please wait...
Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

©2018 MSPControl | Privacy Policy

Log in with your credentials

or    

Forgot your details?

Create Account