This topic has 7 replies, 5 voices, and was last updated 3 years ago by Bogdan Cerbulescu.

  • Author
    Posts
  • #5812

    I upgraded to the latest MSPControl yesterday and now when I click on any Website I get the following error:

    http://cpanel.etghost.net/Default.aspx?pid=SpaceWebSites&mid=34&ctl=edit_item&ItemID=696&SpaceID=98
    Logged User: serveradmin
    Work on Behalf: AppleCreek
    Hosting Space: 98
    Stack Trace: System.Web.Services.Protocols.SoapHeaderException: System.Web.Services.Protocols.SoapHeaderException: Microsoft.Web.Services3.Security.SecurityFault: The signature or decryption was invalid —> System.Security.Cryptography.CryptographicException: WSE523: The CipherData contents are invalid.
    at Microsoft.Web.Services3.Security.Cryptography.SymmetricEncryptionFormatter.Decrypt(Byte[] data)
    at Microsoft.Web.Services3.Security.EncryptedData.Decrypt(XmlElement encryptedElement)
    — End of inner exception stack trace —
    at Microsoft.Web.Services3.Security.EncryptedData.Decrypt(XmlElement encryptedElement)
    at Microsoft.Web.Services3.Security.EncryptedData.Decrypt()
    at Microsoft.Web.Services3.Security.Security.LoadXml(XmlElement element)
    at Microsoft.Web.Services3.Security.Security.CreateFrom(SoapEnvelope envelope, String localActor, String serviceActor)
    at Microsoft.Web.Services3.Security.ReceiveSecurityFilter.ProcessMessage(SoapEnvelope envelope)
    at Microsoft.Web.Services3.Pipeline.ProcessInputMessage(SoapEnvelope envelope)
    at Microsoft.Web.Services3.WseProtocol.FilterRequest(SoapEnvelope requestEnvelope)
    at Microsoft.Web.Services3.WseProtocol.RouteRequest(SoapServerMessage message)
    at System.Web.Services.Protocols.SoapServerProtocol.Initialize()
    at System.Web.Services.Protocols.ServerProtocolFactory.Create(Type type, HttpContext context, HttpRequest request, HttpResponse response, Boolean& abortProcessing)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at MSPControl.Providers.Web.WebServer.GetSite(String siteId)
    at MSPControl.EnterpriseServer.WebServerController.GetWebSite(Int32 siteItemId)
    at MSPControl.EnterpriseServer.esWebServers.GetWebSite(Int32 siteItemId)
    at MSPControl.EnterpriseServer.BusinessErrorCodes.GetMessage(SoapException ex)
    at MSPControl.Portal.MSPControlModuleBase.ShowErrorMessage(String moduleName, String messageKey, Exception ex, String[] additionalParameters)

    0
    Be the first one to like this.
    Please wait...
    #5814
     MSPControl
    Keymaster

    If this is a multi-server deployment its possible that all the server components don’t match with the ES.

    0
    Be the first one to like this.
    Please wait...
    #5815

    They all match. Everything is 1.0.0.2654

    0
    Be the first one to like this.
    Please wait...
    #5817
     Alexander
    Member

    Please go to Servers and make sure the password is correct. Try to reset the password of Server component, you could use the standalone installer for it.

    0
    Be the first one to like this.
    Please wait...
    #5897

    I have a similar problem. Pretty sure along the same lines.
    It seems that I can no longer access the remote servers to save changes.
    I tried changing the password under servers, and then I get the exact error as you.
    Did you manage to figure it out?

    System.Web.Services.Protocols.SoapHeaderException: System.Web.Services.Protocols.SoapHeaderException: Message did not meet security requirements.
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at MSPControl.Providers.ServiceProvider.Install()
    at MSPControl.EnterpriseServer.ServerController.InstallService(Int32 serviceId)
    at MSPControl.EnterpriseServer.esServers.InstallService(Int32 serviceId)
    at MSPControl.EnterpriseServer.BusinessErrorCodes.GetMessage(SoapException ex)
    at MSPControl.Portal.MSPControlModuleBase.ShowErrorMessage(String moduleName, String messageKey, Exception ex, String[] additionalParameters)

    0
    Be the first one to like this.
    Please wait...
    #5902
     Alexander
    Member

    What the version of Windows Server do you use?

    0
    Be the first one to like this.
    Please wait...
    #6215
     Ballou
    Member

    Hi, I have the same error.
    Windows Server 2012R2
    Latest MSPC.

    0
    Be the first one to like this.
    Please wait...
    #6218

    You need to install the installer on each msp server, and then modify configuration, and then create a new server password.
    Then, update the password in the portal (under servers), and it should work.

    2
    2 people like this.
    Please wait...
Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘CipherData contents are invalid’ is closed to new replies.

©2020 MSPControl | Privacy Policy

Log in with your credentials

or    

Forgot your details?

Create Account